• Advertisement

Help with 3825 and 3560 setup

VTP, Portfast, Spanning Tree and all the other switch related stuff.

Help with 3825 and 3560 setup

Postby Guest » Tue Feb 20, 2007 3:23 am


Hi proz,

       I need help configuring my 3825 router and 3560 switch for voip setup.

1)Basic configuration(as these are out of box).Any config docs or step by step guidance would be great.

2)Enable dhcp on both the devices.

3)Auto qos need to be enabled for all the vlans.

Ip address DATA - 105.152.40.0/23

VOICE - 105.152.240.0/24

needs to be assigned.

your help or post would be of great help.

Thanks in advance.

 

Guest
 

Advertisement

Re:Help with 3825 and 3560 setup

Postby Guest » Tue Feb 20, 2007 4:45 am


Hi there,

Are you going to be using a Cisco CallManager) server, or will you be using CallManager Express (CCME), or are you going to be connecting your 3825 to a PBX and using the router as an analog voice gateway?

Anyway, here's a basic router config (no DHCP, no voice interfaces (not sure what you have)):

version 12.4

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname <your hostname here>

!

boot-start-marker

boot-end-marker

!

logging buffered 8192 informational

enable secret <your enable password here>

!

no aaa new-model

!

ip cef

!

no ip domain lookup

!

archive

log config

  hidekeys

!

class-map match-any BULK

description Bandwidth Intensive Interactive Data Applications

match ip dscp af32

match ip dscp af33

class-map match-any SIGNALLING

description VOIP Signalling

match ip dscp cs3

class-map match-any REAL-TIME

description REAL-TIME Traffic

match ip dscp ef

class-map match-any INTERACTIVE

description Interactive Data Applications

match ip dscp af21

match ip dscp af22

match ip dscp af23

class-map match-any VIDEO

description Video Conference

match ip dscp af41

match ip dscp af42

match ip dscp af43

!

policy-map QOS-OUT

class REAL-TIME

  priority percent 30

class VIDEO

  bandwidth percent 15

class BULK

  bandwidth percent 15

class INTERACTIVE

  bandwidth percent 10

class SIGNALLING

  bandwidth percent 5

class class-default

  fair-queue

  random-detect

!

interface GigabitEthernet0/0

description Connection to your switch port FastEthernet0/1

no ip address

ip route-cache flow

load-interval 30

duplex full

speed 100

media-type rj45

service-policy output QOS-OUT

!

interface GigabitEthernet0/0.10

description DATA

encapsulation dot1Q 10 native

ip address 105.152.41.254 255.255.254.0

!

interface GigabitEthernet0/0.20

description VOICE

encapsulation dot1Q 20

ip address 105.152.240.254 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 105.152.240.254

!

interface GigabitEthernet0/1

no ip address

shutdown

!

no ip http server

no ip http secure-server

!

line con 0

password <your telnet password here>

stopbits 1

line aux 0

password <your telnet password here>

transport input telnet

stopbits 1

line vty 0 4

password <your telnet password here>

transport input telnet

line vty 5 15

password <your telnet password here>

transport input telnet

!

end

With the DHCP configuration, that should be enough to get your phones on one VLAN and your PCs on another, plus set the router up as an H323 gateway.  I haven't included any voice hardware configuration (voice port) or dial-peers to the router as I don't know what WICs you're going to use (FXO, FXS, T1/E1, E&M, etc) or if you're using CallManager, CallManager Express, or just gateway-to-gateway.

Hope this is of some help anyway

Kind regards,

Graeme

Guest
 

Re:Help with 3825 and 3560 setup

Postby Guest » Tue Feb 20, 2007 5:26 am


And here's the config for the switch:

version 12.2

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname <Your hostname here>

!

enable secret <Your enable password here>

!

no aaa new-model

!

system mtu routing 1500

vtp domain NON-VTP

vtp mode transparent

udld enable

ip subnet-zero

no ip source-route

no ip domain-lookup

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10

name DATA

!

vlan 20

name VOICE

!

interface FastEthernet0/1

description Connection to your 3825 port G0/0

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 1,10,20

switchport mode trunk

priority-queue out

auto qos voip trust

mls qos trust dscp

!

interface range FastEthernet0/2 - 24

switchport access vlan 10

switchport mode access

switchport voice vlan 20

no logging event link-status

no snmp trap link-status

priority-queue out

auto qos voip cisco-phone

spanning-tree portfast

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

mls qos map cos-dscp 0 8 16 24 32 46 48 56

!

interface Vlan1

no ip address

!

interface Vlan10

description DATA

ip address 105.152.41.240 255.255.254.0

!

ip default-gateway 105.152.41.254

ip classless

no ip http server

!

control-plane

!

line con 0

exec-timeout 15 0

password <your console password here>

line vty 0 4

exec-timeout 15 0

password <your telnet password here>

length 0

line vty 5 15

exec-timeout 15 0

password <your telnet password here>

length 0

!

end

Guest
 

Re:Help with 3825 and 3560 setup

Postby Guest » Tue Feb 20, 2007 6:02 am


Need trunking established from router to switch and qos enabled on switch for voice and all ports configured on swith for phones.

I have only to setup router and switch setup,i dont have to worry about T1 and dial peers(voice components).

I need to create a management IP on the switch to enable telnet to it for management.

Default route on router will be 105.152.41.254 ( which is the ip address of wan router).

Enable dhcp on both networks such that i can test my configuration with a pc and ip phone.

And finally,i need to setup router in such a way that it is password protected from telnet and console.

Guest
 

Re:Help with 3825 and 3560 setup

Postby Guest » Tue Feb 20, 2007 6:22 am


Hi there,

I set up trunking - your Gigabit 0/0 interface on the 3825 config is divided into Subinterfaces G0/0.10 and 0/0.20.  Note the "encapsulation dot1q" command on the router.

If you also look at F0/1 on the 3560 config, that has been configured to do 802.1Q trunking between the switch and the router.  Configure your switch and router and connect G0/0 on the router to F0/1 on the switch and they will establish a 802.1Q trunk with VLAN 10 being native.

The VLAN 10 interface on the switch has been configured with a management IP address (there's no problem having a management IP address from the data VLAN; all our switches have this).

You would probably be better off with an actual server running your DHCP service, and using DHCP relay from the subinterfaces of the router, but I can get you a DHCP scope config tomorrow if you like.

AutoQoS is enabled on all the switchports and I've given you some QoS config for the router (need more info to be able to do any better, unfortunately).

On the lines that say "<your telnet password here>" just replace that with a password of your choice before pasting the config on to the router/switch.

Guest
 

Next


  • Advertisement


Similar topics


Return to Cisco Switching

Who is online

Users browsing this forum: Google [Bot] and 1 guest