• Advertisement

ASA Keeps booting to Rommon!

Firewalls, PIX, ASA, VPN, Access Control List, User Authentication, Data Encryption and Best Practices.

ASA Keeps booting to Rommon!

Postby Guest » Sun Aug 08, 2010 1:50 am


Hello,

I recently had to re-format, add a new activation-key, and add the asdm504.bin and asa704-k8.bin to my ASA 5520 (I accidentaly erased the memory on the machine). Now currently everytime I use the "reload" command it just loads straight into Rommon#.... when I get to the Rommon# prompt all I have to do is type....  "boot" and it loads my asa704-k8.bin file and loads up my config and looks good. I am just wondering is there a way that I would be able to easily set it so it loads the image automatically?

asa2(config)#show boot

BOOT variable = disk0:/asa704-k8.bin

Current BOOT variable = disk0:/asa704-k8.bin

CONFIG_FILE variable = disk0:/startup-config

Current CONFIG_FILE variable = disk0:/startup-config

asa2(config)# show disk0:

Initializing disk0: cache, please wait....Done.

-#- --length-- -----date/time------ path

  8 2995       Jun 07 2006 06:30:02 startup-config

  9 5437440    Jun 07 2006 06:18:04 asa704-k8.bin

10 5958324    Jun 07 2006 06:24:08 asdm504.bin

51515392 bytes available (11431936 bytes used)

Thanks,

Chris

Guest
 

Advertisement

Re:ASA Keeps booting to Rommon!

Postby Guest » Sun Aug 08, 2010 2:04 am


Hi,

try adding the "boot system disk0:/asa7xx-k8.bin" to your config.

Kind Regards,

Tom

Guest
 

Re:ASA Keeps booting to Rommon!

Postby Guest » Sun Aug 08, 2010 3:32 am


Tom,

Thanks a lot for the response, I gave that a try and I got the following error. I have no clue what is going on and I dont know why it wont boot the image.... even though it says it should.

icm-asa2(config)# boot system disk0:/asa704-k8.bin

ERROR: Unable to set this url, it has already been set

Remove the first instance before adding this one

Thanks,

Chris

ps: Im not sure but I have a feeling its something I have to set within the Rommon prompt but I have no idea what.... Unfortunately

Guest
 

Re:ASA Keeps booting to Rommon!

Postby Guest » Sun Aug 08, 2010 4:16 am


Hi Chris,

could you have a look in the config and see if the is already a "boot system" command present? Remove it (if it's there) and replace it with the right one.

Regards,

Tom

Guest
 

Re:ASA Keeps booting to Rommon!

Postby Guest » Sun Aug 08, 2010 4:16 am


Tom,

I took a look at the config and the only "boot system" command was pointing to my asa704-k8.bin file so I am really at a loss here. I am fairly certain as I mentioned it must be something in Rommon that needs to be set at initial boot but I am just not sure what to set to make it so its doesnt boot into Rommon and just loads my .bin file.  Any other suggestions?

Here is a readout of what it says after I reload:

Evaluating BIOS Options ...

Launch BIOS Extension to setup ROMMON

Cisco Systems ROMMON Version (1.0(10)0) #0: Fri Mar 25 23:02:10 PST 2005

Platform ASA5520

Management0/0

Ethernet auto negotiation timed out.

Interface-4 Link Not Established (check cable).

Default Interface number-4 Not Up

Use ? for help.

rommon #0>

I am not sure why it is trying to use the Interface-4?

Thanks a lot for the help,

Chris

Guest
 

Next


  • Advertisement


Similar topics

Can't access rommon in 3548-XL switch
Forum: Cisco Switching
Author: moderada
Replies: 0

ROMMON Upgrade
Forum: Cisco Switching
Author: Anonymous
Replies: 3

65K image verified & bootvar all good - ROMMON
Forum: Cisco Switching
Author: Anonymous
Replies: 12

877 ROMmon upgrade
Forum: Anything Networking
Author: Anonymous
Replies: 4

rommon> mode only
Forum: Cisco Switching
Author: Anonymous
Replies: 4


Return to Cisco Security

Who is online

Users browsing this forum: Bing [Bot] and 2 guests