Can you port-channel a Gen1 Line Rate port and a Gen2 Dedicated port

Support for NAS servers.
Guest

Can you port-channel a Gen1 Line Rate port and a Gen2 Dedicated port

Post by Guest » Thu Sep 07, 2006 11:30 pm


I tried to port channel a port from a Gen 1 16 port line card and a Gen 2 24 Port card.  I had the gen 1 port set to auto auto and by default it's running dedicated.  The gen 2 port was set by default to shared which didn't allow the E port to come up.  I changed it to dedicated and the ISL port came up as a TE but when I tired to port channel it with the gen 1 port I got speed mismatch errors.  I then set them both to auto/auto and it still didn't work.  Set the gen 2 port to 2GbMax and then it complained.  Is this just an issue with a blade that has port groups and one that doesn't?

Guest

Re:Can you port-channel a Gen1 Line Rate port and a Gen2 Dedicated port

Post by Guest » Fri Sep 08, 2006 1:01 am


you can create the port channel between the 2 by following these steps.On the 16 port line card.- hard code port to 2GBOn the 24 port line card- hard code port to 2GB dedicatedCreate the port channel interface with speed = 2GBYou should then be able to add the ports from the gen1 and gen2 line cards to the port channel.You may also have to hard code the ports to E on both line cards.What the port channel configuration looks for is an exact match in speed and mode.  IE: if both the get 1 and get 2 are set to speed = Auto, it will fail because the gen 2 could negotiate to 4GB while the gen 1 can only negotiate to 2GB...so they must be both manually set to the speed value of the port channel.  (speed on the port channel is not the aggregate, but the link speeds in the port channel)Same applies for port mode.  If one is Auto and one is E, it will fail.  Set the port channel and the individual ports to mode = E and it should work just fine.Hope this helps,  Mike

Guest

Re:Can you port-channel a Gen1 Line Rate port and a Gen2 Dedicated port

Post by Guest » Fri Sep 08, 2006 1:45 am


Mike,thanks. That makes sense.  I kind of figured it was something wasn't all apples to apples with the two ports and since I had other ports that were available on teh Gen 2 blade that knew would work I just used one of those.  I'll keep this for future reference.

Post Reply