Sending faxes with FXS port

Cisco CallManager, Cisco CallManager Express and IP Video
rcraig114
Hello I'm new here
Posts: 1
Joined: Mon Jul 04, 2011 8:46 am

Sending faxes with FXS port

Post by rcraig114 » Mon Jul 04, 2011 8:49 am

I have setup a fax machine with one of my FXS ports. Receiving faxes works great, but sending does not work. When the fax starts to send, I can hear the machine dial the number (the speaker on the machine is rather loud), the distant end answers the call, but then after the first second or two of the high pitch noise that fax machines use to communicate, the FXS card hangs up the call. Is there something that is causing this by default? From what I've read, to use a fax machine with an FXS card requires you to configure the FXS port like a normal analog phone, which doesn't require much configuration. Can anyone point me in the right direction or have any suggestions? Below is a copy of my config. Thanks!


no aaa new-model
voice-card 2
!
voice-card 3
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.3.1 192.168.3.25
!
ip dhcp pool ITS
network 192.168.3.0 255.255.255.0
option 150 ip 192.168.3.1
default-router 192.168.3.1
dns-server 8.8.8.8
!
!
ip name-server 8.8.4.4
ip name-server 8.8.8.8
multilink bundle-name authenticated
!
!
!
voice service pots
fax rate disable
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711ulaw
h323
sip
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
description VOIP Network
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
h323-gateway voip bind srcaddr 192.168.3.1
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
no ip http secure-server
ip http path flash:/gui
!
tftp-server flash:SCCP41.8-2-2SR1S.loads
tftp-server flash:apps41.8-2-2es1.sbn
tftp-server flash:cnu41.8-2-2es1.sbn
tftp-server flash:cvm41sccp.8-2-2es1.sbn
tftp-server flash:dsp41.8-2-2es1.sbn
tftp-server flash:jar41sccp.8-2-2es1.sbn
tftp-server flash:term41.default.loads
tftp-server flash:term61.default.loads
tftp-server flash:/7970-7971/apps70.8-2-2es1.sbn alias apps70.8-2-2es1.sbn
tftp-server flash:/7970-7971/cnu70.8-2-2es1.sbn alias cnu70.8-2-2es1.sbn
tftp-server flash:/7970-7971/cvm70sccp.8-2-2es1.sbn alias cvm70sccp.8-2-2es1.sbn
tftp-server flash:/7970-7971/dsp70.8-2-2es1.sbn alias dsp70.8-2-2es1.sbn
tftp-server flash:/7970-7971/jar70sccp.8-2-2es1.sbn alias jar70sccp.8-2-2es1.sbn
tftp-server flash:/7970-7971/sccp70.8-2-2sr1s.loads alias sccp70.8-2-2sr1s.loads
tftp-server flash:/7970-7971/term70.default.loads alias term70.default.loads
tftp-server flash:/7970-7971/term71.default.loads alias term71.default.loads
tftp-server flash:desktops/320x212x12/list.xml
tftp-server flash:desktops/320x212x12/campusnight.png
tftp-server flash:desktops/320x212x12/ciscofountain.png
tftp-server flash:desktops/320x212x12/mountain.png
tftp-server flash:desktops/320x212x12/fountain.png
tftp-server flash:desktops/320x212x12/morrorock.png
!
control-plane
!
!
!
voice-port 2/0
no vad
caller-id enable
!
voice-port 2/1
!
voice-port 3/0
description Line to OOMA
caller-id enable
!
voice-port 3/1
!
!
!
sccp
!
!
!
dial-peer voice 100 voip
description *** Incoming Dial-Peer ***
session protocol sipv2
session target sip-server
incoming called-number .
dtmf-relay rtp-nte
codec g711ulaw
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 11 voip
description *** 11 Digit Calls ***
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 911 voip
destination-pattern 911
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 5 voip
destination-pattern 1000
session target ipv4:192.168.1.252
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 30 voip
description 7 digit calls for local area 520 calling
destination-pattern [2-9]......
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 15 pots
destination-pattern 4172083015
port 2/0
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username XXXXXX password XXXXXXXXX realm sip-ua.com
authentication username XXXXXXX password 7 XXXXXXXXX
registrar dns:proxy.sip-ua.com expires 60
sip-server dns:proxy.sip-ua.com
!
!
telephony-service
load 7941GE SCCP41.8-2-2SR1S
load 7970 sccp70.8-2-2sr1s
max-ephones 5
max-dn 5
ip source-address 192.168.3.1 port 2000
auto assign 1 to 5
service phone videoCapability 1
timeouts interdigit 4
timeouts busy 25
system message Welcome home....
url services http://phone-xml.berbee.com/menu.xml
time-zone 7
voicemail 9999
max-conferences 4 gain -6
moh music-on-hold.au
web admin system name XXXXXXXXXX password XXXXXXXXXX
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Jun 25 2011 15:04:12
!
!
ephone-dn 1 dual-line
number 5000 no-reg both
label Desk-Phone
name Desk-Phone
call-forward busy 9999
call-forward noan 9999 timeout 45
!
!
ephone-dn 2 dual-line
number 5001 no-reg both
label House Line 2
call-forward busy 9999
call-forward noan 9999 timeout 45
!
!
ephone-dn 3 dual-line
number 5002 no-reg both
label Rob-Laptop
name Rob-Laptop
call-forward busy 9999
call-forward noan 9999 timeout 45
!
!
ephone-dn 4 dual-line
number 5202269505 no-reg both
label House Phone
name House Phone
call-forward busy 9999
call-forward noan 17605838270 timeout 60
!
!
ephone-dn 5 dual-line
number 5004 no-reg both
call-forward busy 9999
call-forward noan 9999 timeout 5
!
!
ephone 1
video
mac-address 0019.2FEE.A4C8
button 1:1 2:4 3:3
!
!
!
ephone 2
video
mac-address 0250.F200.0001
type CIPC
button 1:3
!
!
!
ephone 3
video
mac-address 000E.8349.D3F5
type ata
button 1:4
!
!
!
ephone 4
video
mac-address 0E83.49D3.F501
type ata
button 1:5
!
!
!
ephone 5
video
mac-address B8AC.6F79.3677
type CIPC
button 1:2 2:4
!
!
!
line con 0
speed 115200
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 XXXXXXXXXX
login
!
ntp clock-period 17208168
ntp server 209.81.9.7
end