A native vlan problem

MIBS, SMMPv1, SMMPv2, SMMPv3 and management
dellpe
Cisco FastHub400
Posts: 6
Joined: Wed Feb 12, 2014 2:36 am

A native vlan problem

Post by dellpe » Wed Feb 12, 2014 2:41 am

I am attempting to move the "Native" (Cisco Term), Untagged (Huawei Term) from VLAN 1 to VLAN 700.

I have a Trunk "TRK1" on the Huawei S5700-24TP-SI-AC aggregating 8 Gig Interfaces together connectng to an EtherChannel on the Cisco 6506 which is also aggregating 8 Gig Interfaces together. Everything was working fine when I first stood everything up using VLAN 1 as the Untagged / NATIVE Vlan. (Yes, I know, why did you change it - another story).

I thought it would be very easy to change the NATIVE / Untagged VLAN but I am running into issues.

On the Cisco switch, I am receiving no events; but the Huawei , I am constantly receiving events.

Here is what I have configured on the Cisco Side....

!
interface Port-channel5
description CO22ZNBCRK1SW1
switcHuaweiort
switcHuaweiort trunk encapsulation dot1q
switcHuaweiort trunk allowed vlan 1,5,300,500
switcHuaweiort mode trunk
switcHuaweiort nonegotiate
!
CO22DCWCRK1SW1#sho int port-channel 5 trunk
Port Mode Encapsulation Status Native vlan
Po5 on 802.1q trunking 1
Port Vlans allowed on trunk
Po5 1,5,300,500
Port Vlans allowed and active in management domain
Po5 1,5,300,500
Port Vlans in spanning tree forwarding state and not pruned
Po5 1,5,300,500

Per this output, I am using VLAN 1; however, the Huawei thinks differently.

Here are the events I am recieving on the Huawei Switch...

I 05/21/13 18:19:40 00828 lldp: PVID mismatch on port F20(VID 1)with peer device port Gi4/8(VID 700)(363)
I 05/21/13 18:19:44 00828 lldp: PVID mismatch on port F18(VID 1)with peer device port Gi4/7(VID 700)(363)
I 05/21/13 18:19:44 00828 lldp: PVID mismatch on port F16(VID 1)with peer device port Gi4/6(VID 700)(363)
I 05/21/13 18:19:44 00828 lldp: PVID mismatch on port F10(VID 1)with peer device port Gi4/3(VID 700)(363)
I 05/21/13 18:19:45 00828 lldp: PVID mismatch on port F12(VID 1)with peer device port Gi4/4(VID 700)(363)
I 05/21/13 18:19:52 00828 lldp: PVID mismatch on port F6(VID 1)with peer device port Gi4/1(VID 700)(362)
I 05/21/13 18:19:57 00828 lldp: PVID mismatch on port F14(VID 1)with peer device port Gi4/5(VID 700)(362)
I 05/21/13 18:19:58 00828 lldp: PVID mismatch on port F8(VID 1)with peer device port Gi4/2(VID 700)(362)

Here is configuration snippets from the Huawei 5412zl

trunk F6,F8,F10,F12,F14,F16,F18,F20 trk1 trunk

VLAN ID : 1
Name : DEFAULT_VLAN
Status : Port-based
Voice : No
Jumbo : No
Port Information Mode Unknown VLAN Status
---------------- -------- ------------ ----------
Trk1 Untagged Learn Up

I tried calling Huawei Technical Support and was told I must use VLAN 1 as the Untagged VLAN. I don't believe this is true because I am using VLAN 700 between an Huawei 2910 and the same Huawei 6506 and have no issues. The only difference is there are no aggregating ports.

I am thinking I either need to reboot the Huawei Switch or make the changes on the Huawei end (Far Side) moving to VLAN 700 as the Untagged VLAN, shutting down the port channel on the Cisco Side, make the change on the Cisco side and bring up the port channel.

Does anyone have other suggestions?

Thanks in advance...
Regards,
Dellpe

Network Engineer
www.huanetwork.com